当前位置:首页 > 问答

黑马建仓主图指标公式

我来帮TA回答

找了好久终于找到您了!求老师帮忙!我经常用的一个很靠谱的主图指标修改成选股公式

该指标有之字(ZIG)函数,不适合做选股或预警公式,请慎用!
==================================
VAR1:=SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),25);
VAR2:=HIGH-REF(HIGH,1);
VAR3:=REF(LOW,1)-LOW;
VAR4:=SUM(IF(VAR2>0 AND VAR2>VAR3,VAR2,0),25);
VAR5:=SUM(IF(VAR3>0 AND VAR3>VAR2,VAR3,0),25);
VAR6:=VAR4*100/VAR1;
VAR7:=VAR5*100/VAR1;
VAR8:=MA(ABS(VAR7-VAR6)/(VAR7+VAR6)*100,15);
VAR9:=(VAR8+REF(VAR8,15))/2;
A:=(VAR7>VAR6 AND VAR7>25 AND VAR6<25);
B:=ZIG(3,50/5)*100;
G:=MA(B,2);
D:CROSS(B,G)*1000;

请高手把通达信“买入必涨”主图指标公式改成选股公式,谢谢!

B1:=EMA((2*CLOSE+HIGH+LOW)/4,5);
趋势:=MA(C,90),COLORRED;
MA14:=MA(CLOSE,14);
码:=COST(50),COLORYELLOW;
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
XG:CROSS(DIFF,DEA);
编写公式,修改公式。盘中预警,条件选股。公式解密,去除或增加时间限制。
点我的用户名,再点私信。

主图出现“黑马”字样预警公式

多空线:=SMA((O+CLOSE+HIGH+LOW)/4,3,1);
强命线:=EMA(COST(81),10);
CTX:=(3*C+H+L+O)/6;
IONG:=(8*CTX+7*REF(CTX,1)+6*REF(CTX,2)+5*REF(CTX,3)+4*REF(CTX,4)+3*REF(CTX,5)+2*REF(CTX,6)+REF(CTX,8))/36;
CTXIONG:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>IONG AND C>O;
XG:=FILTER(CTXIONG,5);
BB1:=CROSS(多空线,强命线);
VBR1:=EMA(CLOSE,8);
VBR2:=EMA(CLOSE,20);
YA:=IF(C>=O,AMOUNT,0);
YAOBV:=SUM(YA,0);
MOBV:=SUM(AMOUNT,0);
BL:=100*YAOBV/MOBV;
MABL3:=IF(BARSSINCE(C)>=3,MA(BL,3),50);
MABL30:=IF(BARSSINCE(C)>=30,MA(BL,30),MABL3);
SSS3:=COUNT(CROSS(VBR1,VBR2),10)>=1;
SSS4:=COUNT(CROSS(MABL3,MABL30),10)=1;
SC:COUNT(XG,5)>=1 AND BB1 AND SSS3 AND SSS4;

麻烦大神帮我把这个主图指标改成通达信选股公示,特别是暴涨黑马那个,谢谢!

特别提示:该指标使用了XMA未来函数,

官方给出的说明,”只供内部测试使用“;

另外,使用该指标选股,目前没有符合条件的个股出现,

可以设置为---

时间段内满足条件(2018-02-14~2018-02-14),可以选取一只个股。

ZK1:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1+XMA(XMA(H,25),25);
ZD1:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))*1;
DY:=CURRBARSCOUNT=1 AND C<REF(C,1);
JJ:=(HIGH+LOW+CLOSE)/3;
QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:=((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,10000,10000);
V2:=SMA(IF(C>=REF(C,1),DDX,-DDX/100),2,1);
DY2:=REF(V2,1)-DY;
XG:C>O AND DY2<0.02 AND MA(C,5)>MA(C,60) AND C/REF(C,1)>=1.02 AND H<ZK1 AND L<ZD1;

大神老师帮忙做一个黑马控股的选股公式,谢谢了

{只能这样}

ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}

SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}

ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}

ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}

ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}

ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}

ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}

ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}

REF(ZSHJJ>REF(ZSHJJ,1),1)=1 AND ZSHJJ>REF(ZSHJJ,1)=0 AND ZCMZL>REF(ZCMZL,1) AND (ZZLKP-ZZLJJ)<ZCMZL;

捕捉妖股的选股公式怎样把它安装到通达信软件上

公式在哪里?我帮你安装。